Downgrade from Tensorflow 2.x to 1.15

83
November 29, 2020, at 09:30 AM

I'm running into an issue where I'm unable to downgrade to tensorflow 1.15.

As of now I have the latest version of tf but I'm running into the 'AttributeError module 'tensorflow' has no attribute 'contrib'' error. I've read that this can be fixed by downgrading to tf 1.15 but when I run pip3 install tensorflow==1.15 I get this: "ERROR: Could not find a version that satisfies the requirement tensorflow==1.15 (from versions: 2.2.0rc1, 2.2.0rc2, 2.2.0rc3, 2.2.0rc4, 2.2.0, 2.2.1, 2.3.0rc0, 2.3.0rc1, 2.3.0rc2, 2.3.0, 2.3.1, 2.4.0rc0, 2.4.0rc1, 2.4.0rc2, 2.4.0rc3) ERROR: No matching distribution found for tensorflow==1.15"

What should I do to fix my attribute error?

Answer 1

version 1.15.0 should work

pip install tensorflow==1.15.0

you can check all available distributions for tensorflow on pypi.

READ ALSO
Windows: How to solve port is taken by a process but I can't find it [closed]

Windows: How to solve port is taken by a process but I can't find it [closed]

Want to improve this question? Update the question so it's on-topic for Stack Overflow

74
Angular css style child from parent

Angular css style child from parent

I've got a question:

64
Pythagoras Tree angle

Pythagoras Tree angle

I am writing a Pythagoras Tree on Java program, and I think I am on a good trackHowever, I don't really know how to use the angle

50
Convert object to array in php from wordpress database field

Convert object to array in php from wordpress database field

sorry for this stupid question but i'm trying to beautify a value from a wordpress database fieldI'm trying to get the values as an array or json from the string:

43