Why does IntelliJ give me osgi-related warnings for a project that doesn't use a manifest file?

71
June 20, 2019, at 2:20 PM

After importing an existing project into IntelliJ, on several classes I get an error about org.apache.commons.lang3 classes. The format of the error is "The package 'org.apache.commons.lang3' is not imported in the manifest" when I look at a reference for the StringUtils class from this package that is being used in the class. This error shows itself in my editor as a red squiggly line under the StringUtils class.

Although this error doesn't affect my ability to compile the project, I don't like seeing errors and would like to understand it before disabling it. My project builds off of a .gradle file, and I don't have a .MF file. The gradle file specifies a compile dependency for the aforementioned package.

READ ALSO
Spring JPA: findAll() as HashMap?

Spring JPA: findAll() as HashMap?

Is there a more efficient way to do this?

80
How do I add external FXML from another package to my tab with netbeans

How do I add external FXML from another package to my tab with netbeans

The line to add the external FXML is not working, error:file not found

68
How to read a picture from two rear cameras (Kotlin->Java)

How to read a picture from two rear cameras (Kotlin->Java)

I want two different images from two different back mobile camera so I could extract the z depth of an detected object from those two images

65