Installing NetBeans 8.0.2 with JDK 9.0.1

554
December 25, 2017, at 10:11 PM

When I try to install NetBeans 8.0.2 on my PC (Win10-64bit) I get the error message:

despite that I already installed JDK 9.0.1, as evident in the command prompt:

My path variables are set as follows:

Answer 1

As mentioned, you are getting error when trying to install NetBeans, in that case you can specify the JDK at command line

<netbeans_installer>.exe --javahome "C:\Program Files\Java\jdk1.9.0"

FaqSuitableJvmNotFound

Answer 2

AFAIK Netbeans which supports JDK 9 is yet to release (i.e, Netbeans 9.0 which is in development mode).

And the documentation states this.

By: jkovalsky, 09 Oct 2017

If you have downloaded JDK 9 recently and try to convince your NetBeans 8.2 IDE to run on top of it we will probably disappoint you, because 8.2 version is not designed to work with JDK 9.

In order to use JDK 9 happily you will need to download a NetBeans 9.0 development build from Apache Incubator. For more information please read Geertjan Wielenga's post on Using Apache NetBeans IDE.

Thank you! NetBeans team

I've also faced the same issue with Netbeans 8.2 (but you're trying with Netbeans 8.0.2). So, I installed JDK 8 and the Netbeans installation went fine.

Still if you want to use JDK 9 you can install it alongside with JDK 8. But you need to set JDK path as JDK 8 in the system path (like you did for JDK 9). While installing Netbeans select JDK 8 installation path as JDK for Netbeans.

I hope it'll be helpful.

READ ALSO
FileSystemResource: how to set relative path

FileSystemResource: how to set relative path

I have project structure like this:

308
Java Data Versioning Startegies in Caching

Java Data Versioning Startegies in Caching

I have to bust a cache entry based on an event and normal delete operation will not work as the cache is not write throughThe delete operation is run on a single host

176
Android - NPE attemp to invoke Shared Preferences null object Volley

Android - NPE attemp to invoke Shared Preferences null object Volley

i have taken the data from the server and apikey then afterwards i save it in the sharedpreferenceswhen i want to take the apikey, i have constraint with error like below:

183