IOS problem to discover services when using flutter_blue package

76
May 10, 2022, at 05:20 AM

I'm working on a project that requires the app I am developing with Flutter to connect to the Raspberry pi via Bluetooth and be able to send and receive data.

I used the flutter_blue and flutter_reactive_ble packages and tested the app on my Android phone and it works fine. This app can discover all Raspberry pi services. However, this is not the case on iOS. iPhone cannot detect all Raspberry pi services. The only service that the iPhone can detect is device information. But I need the iPhone to at least be able to detect the GATT service so that it can exchange data with the Raspberry pi.

I appreciate it if anyone can help me with this issue.

Rent Charter Buses Company
READ ALSO
How can I properly initialize my Android emulator using AVD?

How can I properly initialize my Android emulator using AVD?

I'm trying to run an Android emulator from command-line because I couldn't run it from Android Studio (it gave the same problem plus some error messages such as "Time out after 300seconds waiting for emulator to come online" and "The emulator...

130
Android Studio - RecyclerView with API level 19 (API 19)

Android Studio - RecyclerView with API level 19 (API 19)

I need to use RecyclerView with API 19 (API level 19)

100
GMail composer links don't work on Android

GMail composer links don't work on Android

I am using GMail links like

108
junit.framework.AssertionFailedError: Expected<BuildersKt$flowOf$$inlined$unsafeFlow> but was:<kotlinx.coroutines.flow.SafeFlow>

junit.framework.AssertionFailedError: Expected<BuildersKt$flowOf$$inlined$unsafeFlow> but was:<kotlinx.coroutines.flow.SafeFlow>

I am trying to write android test cases for Room Dao, my return type is FlowI am getting the following error which I am not able to understand

155